Plesk updates and server security

Recently we were advised of a significant vulnerability in all older versions of the Plesk Panel. If you have not done so recently, we strongly recommend you schedule some time to update.

Extended details about that are available.

You can follow their instructions to update your Plesk instance.  Or please just pop in a support ticket and we can perform the update for you.

About Glenn Enright

Linux Systems Administrator at RimuHosting.com. I focus mainly on dedicated server provisioning with a sprinkling of network administration.

This entry was posted in Security and tagged , , , , . Bookmark the permalink.

Comments are closed.