Could not perform immediate configuration on already unpacked ‘util-linux’.Please see man 5 apt.conf under APT::Immediate-Configure for details

Today we had a customer who had somehow broken his apt package manager doing an upgrade from the looks. I googled and found the same error in many places, most resorting to reinstalling or purging the package to clear it, or reinstall. The error looked like this