Plesk updates and server security

Recently we were advised of a significant vulnerability in all older versions of the Plesk Panel. If you have not done so recently, we strongly recommend you schedule some time to update. Extended details about that are available. You can follow their instructions to update your Plesk instance.  Or please just pop in a support… Continue reading Plesk updates and server security

Updating old installs – Plesk – and other nasty issues

When choosing a VPS often people go with the distro that suits them best, usually one they find easy to manage. Whilst this is fine, you also need to remember that at some stage in the future you will need to reinstall or upgrade. Debian/Ubuntu based distros seem to scale and upgrade versions fine with… Continue reading Updating old installs – Plesk – and other nasty issues